1 post / 0 new
#1 Thu, 21/11/2019 - 11:41
sotiriss

Warning related to h5py

I am working on some dummy pyspark examples where I just want to read some HDF5 files.
I get the following warning and after a small google search, it seems that the h5py library needs to be upgraded.
/opt/rh/rh-python35/root/usr/lib64/python3.5/site-packages/h5py/__init__.py:36: FutureWarning: Conversion of the second argument of issubdtype from `float` to `np.floating` is deprecated. In future, it will be treated as `np.float64 == np.dtype(float).type`.
  from ._conv import register_converters as _register_converters


Any ideas? Thank you.